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Introduction

Alias’ Maya 5.0 is an incredibly powerful and deep program. A person could
work for months in the program and then one day accidentally stumble upon

a feature that they had no idea was there. Often people working in Maya
become so focused on one particular area that, if asked to work with a toolset
different to those they are familiar with, they wouldn’t be able to make head or
tail of it. That is where this book comes in.

The purpose of this book is to show, by example, the many different work areas
available in Maya 5.0; after following the examples, you will be able to navigate
comfortably through these. The examples are designed to be open-ended; this
means that the workflow from the tutorials can be applied to more complex

scenes.

Follow along and soon you will have the knowledge to model your own
characters, to light a world you have built, to animate a person talking to

himself, or to do anything else you can imagine.

Jason Patnode
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System Specs

Working in 3D is very demanding on your computer. Being such a robust
package means that Maya has some fairly steep requirements. The

requirements listed below are the minimum needed to use the program.

Maya 5.0 system requirements:

Maya Personal Learning Edition has different requirements:

Windows XP Professional.

Windows 2000 Professional (Service Pack 2 or higher).
SGI IRIX 6.2.15.

RedHat Linux 7.3 or 8.0.

Apple Mac OS X 10.2.4 or higher.

Internet Explorer 4.0 or Netscape 7.0 or higher.
Pentium Il or higher.

AMD Athlon or higher.

512 MB RAM.

Hardware-Accelerated OpenGL graphics card.
CD-ROM Dirive.

3-button mouse with mouse driver software.
450 MB of hard disk space.

Windows XP Professional.

Windows 2000 Professional (Service Pack 2 or higher).
Apple Mac OS X (10.2.4 or 10.2.6).

Internet Explorer 5.0 or Netscape® 6.0 or higher.
Pentium Il or higher.

AMD Athlon or higher.

Macintosh G4.

512 MB RAM.

Hardware-Accelerated OpenGL® graphics card.
CD-ROM Drive.

3-button mouse with mouse driver software.

450 MB of hard disk space.

xiii



SYSTEM SPECS

Maya PLE also has the following difference from the commercial version of the

program:

e A watermark appears in the rendered image.

e You cannot render using the Mental Ray or Maya Vector renderers.

e Rendering is limited to a single CPU.

e Images are limited to 1024 X 768.

e The file format is specific to the PLE version (.mp). You cannot save your

scene as (.ma) or (.mb) files. Particle disk caching is not supported.
Text dump from the Blind Data Editor window is not supported
Exporting skin weight maps and character maps is not supported.
The script editor output section is limited to 75 lines of output.

The script editor > Save Selected menu item has been removed.

Once you begin working with very dense scenes, you will always wish you had

more memory and a faster processor. This is not an area to skim on. Max out

your RAM as soon as possible and get the fastest processor you can.

A good starting system would be:

Xiv

2 GHz Pentium 4.

Macintosh G4.

1024 MB RAM.

120 GB 7200 rpm hard drive dedicated to your art.



Common Hotkeys

Menus:

F2
F3
F4
F5

Tools:

Insert

J

j

Alt+Up arrow
Alt+Down arrow
Alt+Left arrow
Alt+Right arrow

Hotbox:

Spacebar (hold)
Spacebar (release)

File:

Loads Animation menu.
Loads Modeling menu.
Loads Dynamics menu.
Loads Rendering menu.

Pivot point edit mode.
Select tool.

Move tool.

Rotate tool.

Scale tool.

Show manipulators.
Snap rotate.

Snap move.

Move up one pixel.
Move down one pixel.
Move left one pixel.

Move right one pixel.

Decrease manipulator size.

Increase manipulator size.

Show hotbox.
Hide hotbox.

Ctrl+s (or Command+s on the Macintosh)

Edit:

z or Ctrl+z (or Command+z on the Macintosh)

z
[

Saves current scene.

Undo.
Redo.

Undo viewport change.

Xv



COMMON HOTKEYS

] Redo viewport change.
Ctrl+d (or Command+d on the Macintosh) Duplicates selection.
Ctrl+g (or Command+g on the Macintosh) Group selection.

P Parents first selection to second.
P Unparent.

Viewports:

a Frame all in current view.

f  Frame selection in current view.

4 Wireframe mode.

5 Shaded mode.

6 Textured and shaded.

7 Textured and lit.

Display:

Ctrl+h (or Command+h on the Macintosh) Hide selected.
Alt+h Hide unselected.
Ctrl+H (or Command+H on the Macintosh) Show last hidden.

Status line:

Snap to curve.
X Snap to grid.
v Snap to point
F8  Toggle selection masks.
F9  Vertex mask.
F10 Edge mask.
F11 Face mask.
F12 UV mask.

Xvi
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Maya 5 was designed from the ground up for complete customizability. Hotkeys,
hotboxes, and shelves are just some of the functions and options that can be
customized on a per user basis. Be aware that Maya is case sensitive. This really
comes into play when working with hotkeys — for instance, ‘p’ has a different
function than ‘P". The former parents one node to another, the latter will
unparent the nodes. Alias has done a good job making Maya similar across all
platforms. This book is written using the PC keyboard. If you are using a
Macintosh and a tool calls for using either the Ctrl or Insert key then you should
use the Command or Home key respectively.

Figure 1.1 Maya’s default startup window.

To navigate properly in Maya you need a three-button mouse. Holding down
the Alt key press the left mouse button to tumble, the middle mouse button
(MMB) to track, or right mouse button (RMB) to dolly.

Tumble rotates the view around the camera’s center of interest. Track moves the

camera horizontally and vertically in the current view. Dolly moves the camera
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view in and out. The track and
_ . Camera Tools _I

dolly tools will work in most

maximize/minimize the current

window. This allows you to move Azimuth Elevation Tool

windows. If you open a window Tumble Tool

and can't see all of the options, Track Tool m |

try to dolly out some. DD"';." Taol ]

Moving your mouse over a Zaom Toal '

viewport window and quickly

tapping the Spacebar will either Rall Taal |
m
m )

quickly and easily between Yaw-Pitch Toal
viewport windows.

Fly Tool

Figure 1.2 The camera move tools.

Tip: By pressing Alt + Shift while tumbling or tracking, the movement will be
constrained to a single axis. Alt + Ctrl + RMB allows you to draw a marquee and
instantly dolly into or away from the selected area.

The Hotbox

Pressing and holding the Spacebar will bring up the Hotbox window. The
Hotbox contains each of the drop-down menu items available in Maya.
The Hotbox can be customized so that only the menus you use frequently will
show up when you access the tool.

1 To customize the Hotbox, press and hold the Spacebar.

2 Click on the Hotbox Controls menu on the right.

3 Using your left mouse button drag to the option you want to enable or

disable and release.

The Marking Menu

A Marking Menu is another tool that can greatly increase your workflow.

Holding down the RMB while working will bring up the Marking Menu of the
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options available at that time. To select an option from a Marking Menu, press
and hold the RMB, highlight the desired tool, and finally release the mouse
button. To select an option from a Marking Menu that is accessed through

the Hotbox, click it with the left mouse button and release. It may seem a bit

awkward at first, but soon you will be able to zip through the different options.

1 To assign a marking menu to a hotbox area and mouse button, go to
Window > Settings/ Preferences > Marking Menus to bring up the

main marking menu window.

2 Select Create New Marking Menu. This will display a marking menu
popup window. Enter EasyMaya as the name in this new window.

3 Using the MMB, drag the icon of the polygonal sphere from the Polygons
shelf onto the uppermost left square in your new marking menu.

4 Click Save and close the marking menu popup window.

5  You will now be in the main marking menu window again. Make sure

Use Marking Menu In is set to Hotbox.

6  Set the Hotbox Region to West. The Hotbox is organized like the points
on a compass: North is up, South is down, East is right, and West is to
the left.

7 Set the Mouse Button to Left and Middle.

8 Click Apply Settings and close.

Go to a viewport in Maya and press the Spacebar. Now if you move your
mouse to the left of the Hotbox and press the left mouse button, your new
marking menu will appear. Click and drag up to the Polygonal Sphere option

and release. A new sphere will appear in your scene.

The Title Bar

The title bar displays which version of Maya you are using as well as the name
of the current scene. If the scene does not have a name it will be listed as
\untitled. The title bar also displays the path for the current scene you are
working on.
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The Status Line

The Status Line contains shortcut icons to many of the more commonly used
Maya tools.

Tl RR|Z+L2efly07 BR|([ME"DC|acZ|ESEE|w]  REE
Figure 1.3 The status line.

Construction History allows you to undo operations. Each operation you perform
on an object is added to its history. When you are happy with the current state
of an object, you can delete its history by going to Edit > Delete by Type >
History. The selection masks allow you to set node types to non-selectable. This
can be very useful if you have a dense scene and need to drag select only
specific object types. The snap tools allow you to snap the current object to the
specified snap type: grid, curve, or point. The Render Current Frame and IPR
(Interactive Photorealistic Rendering) buttons on the Status Line will quickly
become two of the most commonly used tools. These shortcuts will render the

current frame based on the values set in the Render Globals into a new window.

" Render Yiew ' -|0O] x|
IFiIe Miew Render IPR Options Display Help

RN JORETE S ¢

size: 320 240 zoom: 0.483 (Maya Software)

Figure 1.4 Render current frame window.

The IPR has the added benefit of constantly updating as you work. For
instance, if you change a texture while the IPR is open, it will automatically
re-render the change.
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The shelf tabs allow you to create customized toolsets. The icons in the shelves
are shortcuts to various tools. To add a button to your shelf, press Ctrl + Shift
and click on the desired tool in the drop-down menus. A shortcut will appear in
your current shelf. If you change the shelves, remember to click the arrow on
the left-hand side of the shelf bar and select Save All Shelves.

The Menus

The Menu bar displays the drop-down menus available for the current menu
set you are working in. In addition to the unique tools available while working
within a specific menu set, there are six drop-down lists common to each menu
set (File, Edit, Modify, Create, Display and Window).

File — Contains options to load/save scenes and set your project information.
Edit — Contains Undo/Redo functions and object duplication and manipulation.
Modify — Deals with node transform information and conversion.

Create — Contains creation controls for primitives, lights and cameras.

Display — Is where you can set your Maya HUD (Heads Up Display) options.

Window - Is the menu to access various work areas in Maya.

Each drop-down menu is organized into different sub-groups that have
different themes associated with them. This lets you know right away what type
of function you can expect from a particular tool. Many tools have adjustable
options designated by 3. If you need to change the options for a particular
tool, navigate to and click on the 3 next to it. If you are happy with the tool
settings, simply click on the name of the tool and it will apply the most recently
used settings. Many menus can also be made to float on top of your work area.
Floating windows are designated with a double line known as the tear-off line.

To tear off a menu, simply select the double line.

Working with Projects

The first thing you want to do when you begin work on a new project is create

a project directory. This directory will house all files to be used for your current
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project. When you begin work on a different project, you can create a new

project directory.

Hint: If you are using a Windows-based system, avoid creating projects in the My
Documents folder. Maya won't be able to find your textures and references if you
copy your work to a different computer.

When you open or save a scene or import or export a file, it points to the
Scenes folder that is set in your current project. If you need to change to a
different project use File > Project > Set and point to the new project.

Let's create a project to hold all of the scenes you'll be creating from the

tutorials within this book.

1 Go to File > Project > New to bring up a blank Project window.

2  Click on the Use Defaults button. Unless there are specific needs for the
project you are working on, | suggest that upon creation you select the
Use Defaults option. This will place all of the project folders in their
proper paths.

3  Type Easy Maya in the Name box.
4  For the Location, browse to your C:\ drive.

5 Click Accept.

Il New Project i =III:II X'C.I

Mame |New_F'ru:uieu:t

Location |E:"-.JasunHFncaIHFDcal_chapters

|_I|5tiiene File Locations ﬂ

IEPmiect Data Locations

IB Data Transfer Locations LI
Accept i Uze Defaults Cancel I

Figure 1.5 The Project window.
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You now have a project folder for all of the tutorials you'll be working through.
If you go to your C:\ drive you will see a folder named Easy Maya. The Easy

Maya project will now open each time you start Maya 5.

The File Menu

There are a few items to take special note of in the File menu. Optimize Scene
Size allows you to automatically remove unused data from your scene to reduce
the size of the Maya file. Be wary, though, because Optimize Scene Size is not
undoable. Import allows you to import data from another file. You can import

an entire Maya scene or one of the many other available file types. Export and

Export Selection allow you to export your scene in a different format. You can

also export animation curves into a separate file.

The Edit Menu Edit
Undo
The Edit menu contains undo and redo Reta
) ; o . Repeat "Mew,.."
functions and commands. It is split into six R cenEEamrarts,
areas: undo/redo, keys, delete nodes, i
selection, duplication, grouping, and Capy
. Paste
parenting.
Keys »
Undo and redo perform as they would in any n
elete
other program. You can undo as many times as Delete by Type v
. 3
you have set in your Maya preferences. To set the reenl e
number of undo levels select Window > sl sl
. Select Hierarchy
Settings/ Preferences > Preferences and go to Tnvert Selection
the Undo category. A large Queue Size will slow Select 4l by Type 4
, . . ick Select Set ’
Maya'’s performance, so | wouldn't set it to QL!'C S
Paint Selection Tool o
infinite. | like to set mine to Finite 200.
Duplicate m |
. Duplicate with Transfarm
The Keys sub-group allows you to perform various :
. . o o]
edit functions on animation keys. Many of the E'C'”P 5
. . ngroup
options in the Keys sub-group work the same as Leveler oot ’
their geometry-based equivalent. You can delete e o
a key or copy a key from one place in the Unparent o

timeline, go to a different frame and paste the key

Figure 1.6 The Edit menu.
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into the new time. Scale Keys allows you to change the duration for a range
of keys. You can use the Scale Keys options to also change the start and end
times of your animation. Bake Simulation is used to convert the selected
simulation into keyframes. Once the simulation is baked into keyframes you
can edit the curves as you would any other animation. This is very useful if you
want to use dynamics in a game because most engines will only recognize
keyframe animation so you will have to convert the simulation before it can

be used.

Quick Select Sets are a handy way to easily pick objects and/or components
(vertices, edges, and faces, etc.) that you select regularly. Follow the steps
below to create a Quick Select Set.

1 Select the objects or components you wish to have in your Quick
Selection Set.

2 Choose Create > Sets > Quick Select Set.

3  Type a name for your Quick Select Set. This name will be saved as part

of your scene file.

When you need to pick this Quick Select Set, go to Edit > Quick Select Sets and

choose the name of the desired set.

The Paint Selection tool lets you pick an object’s components by painting them.
This makes component selection very intuitive.
1 Create a new scene by going to File > New Scene.

2 Create a Polygon Plane. Create > Polygon Primitives > Plane > .
Set the Width and Height to 20 and the width and height subdivisions
to 40.

3 Click Create.

4  With the plane still selected, right mouse click on the plane to bring up
the Marking Menu and select Vertex.

5 Choose Edit > Paint Selection Tool > 3.
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6 When the options come up for the Paint Selection Tool, set the Radius
(U) to .5 and leave everything else at the default.

7 Paint your initials on the object to select the components.

Figure 1.7 Painted initials.

The Paint Selection tool makes picking a complex layout of components very
easy. Once you are happy with the paint selection you have made, you can add
it to a Quick Select Set.

Tip: Many functions in Maya can be used with a drawing tablet. If you have a tablet
available, it can make working with the Maya paint tools much easier.

The Modify Menu

The Modify menu is used for object manipulation and conversion. It is split into six
parts: transforms, node evaluation, miscellaneous, attribute, conversion, and paint.

The transformation sub-menu contains the functions needed to move, rotate,

and scale your objects.

10
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Transformation Tools

Figure 1.8 The transform tools.

Figure 1.9 Tools in
the Tool Box.

In addition to access through the drop-down menu and hotkeys, the move,
rotate, and scale tools have permanent buttons in the Tool Box.

By picking one of the transform tools, a manipulator will appear for the selection.

Figure 1.10 The move, rotate, and scale transform manipulators.

The manipulator handles are color-coded to correspond to the X, Y, and Z axes.
Red represents X, green is for the Y axis, and blue corresponds to Z. When using a
manipulator, the handle of the selected axis will become yellow indicating that it is
currently active. When you click on a tool in the Tool Box, it uses the current
settings for that particular tool. To bring up the options for a particular tool, you
can either double click on an icon in the Tool Box to bring up the Attribute Editor
or press and hold the keyboard hotkey while pressing the left mouse button to
display a Marking Menu of the available options.
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To use the Move tool, select and drag an arrow on the manipulator to move
along a specific axis. To move freely, click the yellow square at the center of the
manipulator and drag across the view plane. There are several coordinates
systems you can use to move your selections in Maya. The default coordinate
system is World. When World is selected, the object is set to move along the
world axes. Selecting Object will move your selection in object space. Local will
align the object to match the parent object’s rotation. The Normal option allows
you to move control vertices on a NURBS surface in the U and V directions.

To use the Rotate tool, select and drag a ring on the manipulator to rotate around
a specific axis. To rotate freely, select and drag the imaginary sphere centered in
the rotate manipulator. Click and drag the outermost ring to rotate your object
around the view axis. To rotate an object on its local coordinates, select the Local
radial button. If you select the Global swatch, objects will rotate around the world

space. The Gimbal option will only allow one channel to be rotated at a time.

To scale an object, select and drag a box on the manipulator to scale along
a specific axis. To uniformly scale your object, click the yellow cube at the
center of the manipulator and drag across the view plane.

Freezing the transformations sets the current transform information on the

selected objects as the new zero. To freeze transformations on the selected

Figure 1.11 Before and after Freeze Transformations.

12
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objects, go to Modify > Freeze Transformations. Whenever you move, rotate or
scale an object, Maya calculates the new information starting from zero.

To reset the selected objects back to their zero state, select Modify > Reset
Transformations.

Make Live is a tool that forces curves to snap onto the selected surface. Go to
Modify > Make Live to make a surface live. When an object is live it will draw
as a green wireframe in the viewport. Select Modify > Make Not Live to turn
this function off.

Try making a sphere live.
1  Click on Create > NURBS Primitives > Sphere.
2  Select the plane and go to Modify > Make Live.

3 Select Create > Pencil Curve Tool and draw over the sphere.

Figure 1.12 Live sphere.

Notice how the curve draws directly onto the Live sphere. Making an object
Live allows you to easily trim surfaces or paint directly onto an object using
Paint Effects.

13
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To center the pivot of an object go to Modify > Center Pivot. To freely move an
object's pivot point, press the Insert key to go into pivot point edit mode. Now
the pivot point is unlocked and can be moved to the desired spot without
affecting the object itself. When done, press the Insert key a second time to

return to normal mode.

The Convert sub-menu allows you to convert from one modeling format to another.
For example, if you created a character using NURBS and later decided it needed
to be polygonal, you would go to Modify > Convert > NURBS to Polygons. Being
able to convert an object can be really handy for game production. You can use
SubD or NURBS models for your hi-res cutscenes and later convert these to
polygons for the in-game work. In the options window for the tools, you can even
set the maximum amount of polygons that can be used during the conversion, thus
ensuring you won't go over your limits of your game engine.

The Create Menu

The Create menu is where you create your geometry, curves, lights, and
cameras. This is also where you create locators and sets. A locator is more

Figure 1.13 Locator.

14
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commonly known as a dummy object. It is a non-renderable object that other
nodes can be parented to. To create a locator go to Create > Locator.

A set consists of a group of objects or components. A set at first glance
may look like a group but, unlike groups, sets do not change the scene

hierarchy.

The Display Menu

The Display menu contains all of the user interface settings for Maya 5. To turn
the grid on or off in all viewports select Display > Grid. If you need to change
your grid options go to Display > Grid > 3. You can set the length and width
of the grid as well as the number of subdivision lines.

The Display > Heads Up Display options allow you to show object and scene
information in your viewports.

icads Up Display 51

Figure 1.15 The Heads Up Display.

Figure 1.14 Heads Up
Display options.

| always work with Poly Count, Camera Names, and View Axis checked, and will
turn other options on as needed. But those three let me know if a character fits
within the polygon limits and whether or not it is oriented correctly.

Hide is very important. You can hide selected objects or all objects of a specific
type. Hidden objects will not render. Hiding objects can make your scenes
much easier to work with. Once you are ready for the final render, use the Show

commands to make any hidden objects visible.

15
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The Window Menu

The Window menu is where you access the many different editors available in
Maya. We'll be going over the various editors in more detail in their respective
chapters. Settings/ Preferences is where you go to set your Maya options. It's very
important that before you begin working on your scene that you have all of
your preferences set correctly. Unless your project requires specific settings,

I would leave the majority of the preferences at their defaults. You should make
sure your axis and time settings are correct though. Go to Window > Settings/
Preferences > Preferences.

tr| Preferences

Kinematics
Animation
Manipulators
HUREBS
Palpgons
Settings
Diynamics
Filez/Projects
Keys
Modeling
Rendering
Selection

Timeline
Unda
Modules

Figure 1.16 The Preferences window.

Click on Settings and set the World Coordinate System to Up Axis Y, and make
sure the Working Units and Time are correctly set for your project. Leave the other
Settings options at their defaults. Having the axis Y up will save you countless
hours of frustration. Almost every software program or game engine is Y up, so if
you have to work with other animators or third-party tools you'll be making things
much easier for yourself by setting your axis correctly to begin with.
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Modeling Concepts

Modeling is the actual building of objects in 3D space. The object can be as
simple as a flat plane or as complex as a wilderness ecosystem. Maya 5 has
three different modeling modes available: Polygonal, NURBS, and Subdivision
surfaces (or subD surfaces). Each method has its benefits and disadvantages.

Object types. From left the spheres are Polygonal, NURBS, and
Subdivision.

Figure 2.1

Polygonal modeling has been around longer than the other types and is
generally easier to learn and more straightforward to work with. If you want to
work in video games, polygons are what you will be using. To get smooth,
detailed models with polygons, however, takes a large amount of data, thus

causing the meshes to be much denser and harder to work with on the higher
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end. NURBS, on the other hand, work very well for creating smooth, organic
objects. On the downside, they have a steeper learning curve and are difficult
to use when creating objects with sharp edges. Subdivision surfaces are the
newest modeling method. In essence subD surfaces are a combination of
polygons and NURBS surfaces. They offer many of the advantages of polygons
and NURBS surfaces. For pre-rendered work, subD surfaces are becoming much
more popular. The disadvantages of subD surfaces are the initial high learning

curve and incompatibility with game engines.

Before you begin modeling, you'll want to have concept sketches and a
minimum of a front and side orthogonal view of the model you plan on
building. The concept sketches are for visual reference during model
construction. The orthogonal views, though, will be used directly in Maya to
help you create your model. First, you will need to scan your orthographic
drawings. Next, you will need to bring the scanned images into Maya for use

as a template to build your model.

Figure 2.2 Front and side sketches of a model ready for construction.
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Tip: When creating a character for animation you should only model half of the
object in a neutral pose. Later you can mirror the object and join the two halves
together. This will save you hours of work.

1 Create a new scene by clicking on File > New Scene.

2  Inthe Front viewport select View > Image Plane > Import Image.
3 At the prompt, load the front view sketch of your character.

4 In the Side viewport select View > Image Plane > Import Image.
5 At the prompt, load the side view sketch of your character.

Figure 2.3 Template geometry.

6  Go to Display > Ul Elements > Channel Box/Layer Editor to bring up
the Channel Box or click the Channel Box button on the Status Line.

7  Press the Show the Layer Editor button in the Channel Box.

8 Select Layers > Create Layer in the Layer Editor.
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9  Select the newly created layer.
10 Drag select the two planes in the Perspective view.
11 In the Layer Editor, select Layers > Add Selected Objects to Current Layer.

12 Click the middle box of your layer until it displays an R. If you need to
open the layer for work at a later time, simply click the middle box of
the layer until it is empty.

Now you can go back to your scene and begin modeling. If you need to hide
the template objects for any reason, click the first box of your layer until it is
empty. This will turn off the layer and hide any objects within it.

Tip: Keep in mind that layers are useful for more than just template geometry.
Layers help you organize complex scenes in the same manner as many of the image
manipulation programs available. | like to organize my scenes by having all of the

characters in one layer, the terrain in another, particles in a third, and so on.

Polygonal Modeling

Polygons are probably the most commonly used modeling format. Low-res
polygonal models are used extensively for video games, while hi-res models are
widely used in print and films. Polygons are an extremely easy modeling form

to work with, hence their widespread use.

An important note on polygons: unlike NURBS and subD surfaces, polygons are
made up of straight edges. No matter how much you smooth or tessellate an

object, if you get close enough, the straight edges will be visible.

Polygonal objects can be open or closed shapes. They can also contain multiple
shells (more commonly known as meshes). A shell is a separate, self-contained

mesh that is part of, but not physically connected to, a larger unit.

Tip: The number of meshes contained in your scene usually isn't a problem except
in games. Most game engines not only have limitations on the number of polygons
that can be used, but also on the number of meshes as well. By combining separate
meshes together you can get around this.
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Primitives are the building blocks of modeling. They are a fast and easy way to
get basic shapes into your scene and often a properly lit and textured primitive
will work fine in your scene. Primitives are available for polygons, NURBS, and
subD. In this section we will be focusing on polygonal primitives, but keep in

mind that all primitives function in the same way.

1  Select Modeling from the Status Line pull down or press the F3
shortcut to enter the Modeling menu.

2 Go to Create > Polygon Primitives > Cube. A default cube will appear

in your scene.

Remember, Maya is completely customizable. This is only one method that can be
used to create the cube. You can also go to the Polygons shelf and select the

polygon icon to create a cube, or you can press the Spacebar while in the working
area to bring up the Hotbox controls and create your primitive from there. You can

even create a keyboard shortcut or MEL script to create your object.

There is an option box 3 next to each primitive listing. You can go in and change
the creation options for each primitive if desired. Open the option boxes and
experiment with creating primitives using varied settings. If you create a primitive
and later decide you would like to adjust it, you can do so by selecting the object
and going to the Attribute Editor (Window > Attribute Editor or use the hotkey
Ctrl + a) to make the changes.

1 Go to Create > Polygon Primitives > Sphere to place a sphere in your
scene. Use the move tools to position it so that there is an overlap

with the cube you created a moment ago.

2 Select the sphere, press the Shift key and select the cube. To select
multiple nodes in Maya 5, you hold down the Shift key and click on
everything you want included in the selection. To deselect nodes,

use the Ctrl key.

3  Go to Polygons > Booleans > Difference.

You should now have something similar to Figure 2.4 below.

Mirror Geometry creates a mirrored duplicate of the selected geometry along
a specified axis. There are options included that allow you to merge vertices
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Figure 2.4 Boolean objects.

during the mirroring process or to connect border edges with new faces.
Mirroring geometry is a great workflow habit to get into — you will be saving

yourself half the work.

Smooth Proxy works on the principle of using a low-res mesh to build your
hi-res geometry, but it differs from Smooth in that you do all of your work on a
simple proxy object while a copy of the smoothed final object updates
automatically.

1  Start a new scene.
2 Go to Create > Polygons Primitives > Cube and create a default cube.

3  Select the cube and go to Polygons > Smooth Proxy. Your cube will
now be semi-transparent and there will be a smoothed copy in its

center.

4 RMB click on the original cube to bring up the marking menu and select
Vertex.

5 Select a vertice and move it. The smooth copy will move as well.
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With Smooth Proxy anything you do to the original object will update
automatically on the smooth copy as well.

Other commonly used tools from the Polygon menu are the Create Polygon
Tool and Append to Polygon Tool. The tools allow you to make customized
polygon shapes by placing the vertices where desired. The only restriction is
that any new polygonal faces you create must be at least a triangle. Combine
allows you to select separate meshes and make them into one piece. Reduce
will trim down the number of polygons in your object while keeping your
UVs intact.

The Edit Polygons menu contains the tools for fine-tuning polygons. This is
where you'll find the tools that let you work on not just the polygons, but also

the vertices, edges, and faces that comprise them.
1 Create a polygonal cube with one division each for height, width, and
depth.
2 RMB click on the cube and go into edge mode.

3 Select the top four edges of the cube.

Figure 2.5 Beveled edges.
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N o a b~

Go to Edit Polygons > Bevel > .
Set the Offset to .05.

Set the Segments to 3.

Check the Auto Fit box.

Click Bevel.

Bevel rounds the selected edges. This is a highly useful tool; there are very few

objects that have completely hard corners. Applying a bevel is a simple step

that can lend quite a bit of realism to an object.

1

2

Undo the bevel and select the top four vertices on the object.

This time go to Edit Polygons > Chamfer Vertex. The chamfer function
replaces each selected vertex with a face. Chamfered vertices are

another small touch that can add a great deal of realism to your object.

Figure 2.6 Chamfered vertices.

Select all of the vertices that made up the chamfer. Go to Edit Polygons >

Extrude Vertex. You will now have spikes protruding from the cube. Extrude the
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vertices a few more times and you can come up with some very intricate shapes
quite easily.

Undo the extrusions and chamfer and select Edit Polygons > Cut Faces Tool.
Drag the manipulator over the cube and when you release the mouse button
the tool will slice the cube. You can set up the options for this tool to either

delete or offset the cut portions.

Extract separates the selected faces from the polygonal object. Separate will
separate any shells you have in your object.

The Colors and Normals tools are invaluable for games development.

With these tools you can properly align vertex normals or color your vertices
directly in the model without affecting your texture budget. You can even
reverse the direction of polygon faces to point the normals in the opposite
direction.

1  Start a new scene in Maya and create a sphere with a radius of 5 and
100 subdivisions along the Axis and Height.

2  Go to Edit Polygons > Sculpt Polygon Tool > 0.

Figure 2.7 Sculpted polygons.
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5

6

Set the Radius{U} to .500 and the Radius{L} to .100. The U is the
maximum size the brush can become, while the L is the smallest size.

Click the first Shape button.
Change the Opacity to .100 and set the Operation to pull.

Paint your name on the sphere.

Tutorial: Creating a Snake

Let's begin building a polygonal character. I'm going to be using a snake

character | created for one of my animations. He's not really an evil character

per se, he's just hungry all the time. This snake is on a never-ending hunt for

food and he is ready to eat anything that moves.

1

Set up a template for your scene and import the orthogonal views of
your object onto the image planes.

Create two more layers. Name one layer hideMe and the other
geometry. Turn the visibility off for the hideMe layer. The hideMe layer

Figure 2.8 EP curve outline.
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will contain things that will aid in building the object, but that we don’t
want in your final scene. The geometry layer will be for your character.

3 Go to the Side viewport and create an EP curve outline of your
character that matches the template.

4  If needed, RMB click on the EP curve and use the Control Vertices and
Edit Point options to fine-tune the curve.

Tip: If you need more edit points to work with, RMB click on the curve and select
Curve Point. Click the spot on the curve that you would like to place your new edit
point and go to Edit Curves > Insert Knot.

5  Once you are happy with the curve, go to Surfaces > Planar > 3. Set
the Degree to Cubic. For the Curve Range click Complete. Choose
Polygons as the Output Geometry with the Type set to Quads, and the
Count set to 100. Click the Planar Trim button. Using a lower polygon
count here is very important. If you set the count too high, your model
will be too difficult to work with later.

Figure 2.9 The flat outline.
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10

11

12

Place the EP curve in the hideMe layer. Because hideMe is already a
hidden layer, anything you add to it will also become hidden.

Select your mesh and rename it to snakeLow. Maya scenes can become
very hectic very quickly; by renaming things now, you'll have a much

easier time keeping track of things.
Delete the history for snakeLow.

Now we need to match the edges of the mesh to the template. RMB
click the mesh and go into Vertex component mode. Using the Move
tool, adjust the vertices so they match the outline. You'll notice some
areas that you can’t match because of the low polygon count. To
correct these use the Split Polygon Tool.

Go to Edit Polygon > Split Polygon Tool. Click the tool where you want
to begin the split and again where you want it to end. Press Enter on

your keyboard to finalize the split.

Continue using the Split Polygon Tool along with moving vertices until the
mesh edges roughly match the outline. Keep in mind that you want to
keep the polygon counts low at this stage so don't try to match things up
exactly. That will all be done later.

The snake has a couple of ridges that run down its side. Use the Split
Polygon Tool to add these ridges to the snakeLow mesh.

Figure 2.10 The added ridges.
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13

14

15

16

17

30

Using a planar trim and splitting polygons can sometimes lead to extra
vertices. We need to clean these up before we continue. Go into vertex
component mode for the mesh and select every vertex.

Select Edit Polygons > Merge Vertices > 3. The Merge Vertices tool
works by combining any vertices within the distance you set. The trick
here is to merge overlapping vertices with just the right amount,
otherwise you will wind up with a mangled snake. If you set it too high,
undo and lower the amount before trying again.

You should go over the model to see if there are any areas that could
benefit from a higher power of merged vertices. Cleaning up any loose
vertices now can save you a great deal of frustration later.

We are now ready to add some depth to the character. Before you
begin, make sure Polygons > Tool Options > Keep Faces Together is
checked. This option forces the selected faces to extrude as one. If you
turn this off, each face would extrude as its own entity.

Go into face component mode and select all of the faces of the snake.

Figure 2.11 Extruded snake.
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Go to Edit Polygons > Extrude Face. There are move, rotate, scale
handles on the Extrude tool. Drag the X move handle until the extrusion

roughly matches the template in the front viewport.

Now you need to adjust the vertices so they match the front view of
your template. Take extra care not to move the vertices that lie on the
zero coordinates. We are building half of the snake now and will mirror
later; if you move the inside vertices, you won't be able to mirror the
object correctly.

Select the faces that make up the ridge and extrude them to match the
template.

Delete the faces on the bottom of the snake.

Select the faces at the front of the neck and extrude them forward to

make the basic form of the head.

Now that we have the basic form for the snake, let’s create the other half.
We won't actually do any work on the second mesh; it’s just for visual

reference. Having both halves visible will help you shape the model.
Select the mesh and go to Edit > Duplicate > .

Set the X scale to —1. Using a negative scale during a duplicate

operation mirrors the object.

For Geometry Type, use Instance. An instances object will update

automatically any time you change the original object.

Set Group Under to Parent. Make sure Smart Transform and Assign
Unique Names to Child Nodes are both off.

Press Duplicate.

Continue to mold the snake to match the main shape of the template.
Remember to work only on the original mesh; any changes you make
will automatically pass down to the other models. Use the Split Polygon
Tool to create more detail in a particular area if it is needed.

Once the main shape is done, use the Split Polygon Tool to create the

outline for the eyebrow and eye.
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Figure 2.12 Second half.

Figure 2.13 Eyes created using the Split Polygon Tool.

31 Push and pull the vertices until you have properly shaped the brow and

eye.

32 Select the new polygons that make up the faces of the eye. Go to Edit
Polygons > Extrude > 3. Set the X translate to —.004 and the X, Y, and
Z scales to .75. Click Apply.
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36

37

38

Delete the faces that you extruded. We want to create the actual
eyeball later. The reason for extruding the faces before deleting them is
that this adds a bit of depth to the eye socket.

Next use the Split Polygon Tool to create an outline for the nose.

When the nostril outline is ready, extrude the faces that are to be the
actual cavity back.

Again use the Split Polygon Tool to draw an outline of the mouth.
Notice the creation of the top and bottom of the mouth. This is a very
important step. By creating the full outline of the mouth, it will make
constructing the inner mouth much easier.

For creation of the inner mouth you should hide all but the main mesh.
This will allow you to get inside the snake’s mouth. Select the three

other meshes and go to Display > Hide > Hide Selection. Don't worry
this in no way affects your models. We just need to hide them until we

are finished creating the mouth.

Now back to the main mesh. Select the inner row of faces of the mouth
outline and delete them. Select the two edges that form the front end
of the top jaw.

Figure 2.14 Creating the inner mouth.
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41

Go to Edit Polygons > Extrude Edge. Click the Local/World switch on
the extrude manipulator so you will be extruding in world space.
Extrude the edges back until they line up with the first vertex of the top

jaw.

With the edges still selected, go to Edit Polygons > Extrude Edge
again. This will create the next segment of the inner mouth. Extrude
this back until it lines up with the next vertex of the top jaw. Do this
for each vertex of the top jaw. Remember to go into world space each
time you extrude here. Once these are finished, create some extra

segments to extend down into the throat.

Now you need to line up the vertices of the segment you created. Select
the vertex nearest the first jaw vertex, go into Snap to Points mode, and
snap the points together. Continue until each segment is snapped to the
proper jaw vertex. The segments you created for the throat won't need
to be snapped to anything. Once finished, turn off Snap to Points.

Figure 2.15 Snapping the vertices.

42 There will now be two vertices at each top jaw position. Use Merge

34
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45
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49

Follow the steps above to create the bottom half of the inner mouth.

Go to Display > Show > Show Last Hidden to display all of the snake
meshes.

Now you need to complete the bottom half of the snake. Select the
bottom edges and extrude them down. Make sure you are in world
space during the extrusion. Also, extrude down in chunks so that your
object has enough faces to deform properly during animation.

After each extrusion, adjust the edges in the side view to match your
desired curvature.

Once you are happy with the length, go to the front view and begin
matching the vertices to the snake’s front view.

Figure 2.16 Creating the bottom half.

You are now ready to merge the pieces into one. Select both halves of
the lower polygon snake and click on Polygons > Combine.

This will create a new mesh node. Delete the history on this node and

rename it snake.
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50 Go into the front viewport, select the center column of vertices and run
a low-strength Merge Vertices operation. This will clean up any

overlapping vertices.

51 All that is left now is to create eyeballs and a tongue. These are each
made from a simple primitive by pushing and pulling vertices into the
desired shapes. Once complete, duplicate the eye and put one in each
socket and position the tongue inside the throat.

52 Your model is now done.

Figure 2.17 The final snake.

The final combining of the halves was done on the low polygon version
because this affords you the most options. If you need to keep a low polygon
version, it is ready to go as is. But if you can go with a higher resolution, simply
run a smoothing operation on the model; we already know this works. You can
even run multiple smoothing operations on it and go ultra-high res. | didn't
extend the template down for the snake because the tail section was very
similar to the main body of the snake. Also, | modeled the head in the arched
position to get more of a menacing look to the snake. Before this could be

used for animation, the head would need to be turned up for proper rigging.
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NURBS Modeling

NURBS (short for Non-Uniform Rational B-Spline) is great for modeling organic
shapes. A NURBS object comprises curves and surfaces.

The curves you create act as a framework for you to stretch a surface over.
Curves have many uses in Maya. Not only are they used for creating geometry,
but curves can also be used for creating text, setting animation paths, and for

controlling character animation rigs.

Figure 2.18 The different curves.

If curves act as the skeleton, surfaces would be the skin laid on top of these
curves. Usually you will manually create NURBS surfaces using tools like Loft,
Revolve, and Extrude, but there are also primitives available in Create > NURBS
Primitives to aid in your modeling. Working with surfaces is similar to working
with curves. Just keep in mind that a curve has one direction to work with,
whereas a surface has two directions (U and V). The U and V directions are used

to form the N (or surface normal) direction.

Go to the Create window. In the curves sub-group you will see the CV (control

vertices) Curve, EP (edit points) Curve, and Pencil Curve tools. The CV Curve
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tool creates curves by placing a control vertex at each mouse click. The EP
Curve tool places an edit point with each mouse click. To create a free flowing
curve, use the Pencil Curve tool. After placing the points of your curve you
need to press the Enter key to finalize it.

To edit a curve RMB click on it to go into component mode. Use the Control
Vertex and Edit Point options to manipulate the shape of the curve. Selecting
Curve Point allows you to fine-tune the curve by adding an edit point at the
specified spot using the Edit Curves > Insert Knot tool.

1 In the top viewport, create an EP curve.

2  In the front viewport create a NURBS circle oriented on the Z axis.
3 Select the circle then the EP curve.
4

Go to Surfaces > Extrude. When you extrude, you first select your
shape followed by the path. You should have a tube similar to the one
below. Tube is the default extrusion method.

Figure 2.19 Extruded circle.

Undo the extrude operation, select the EP curve first and the circle second. If
you run the Extrude tool now, it will use the circle as the path and create an
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entirely different shape. Of course, if Construction History is still on, you

can continue to manipulate the curves to alter the surface.

Tutorial: Binoculars

1

2

Start a new scene in Maya 5.

In the top viewport create an EP curve similar to the one shown in
Figure 2.20.

With the curve selected, go to Surface > Revolve > .
Set the Axis Preset to Z and the Pivot to object.

For Surface Degree select Cubic and use 0.00 for Start Sweep Angle
and 360 for the End Sweep Angle. This will create a solid shape. If you
started and ended at different angles, you would get a different
surface.

Choose 8 for Segments. Set the Curve Range to Complete and NURBS
as the Output Geometry. Click Create.

Figure 2.20 EP curve before and after revolve
operation.
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Figure 2.21 Isoparms needed to build the crosspiece.

Now you need to build the crosspiece. Select two adjacent isoparms

partway along the barrel of the revolved binocular barrel.

Go to Edit Curves > Duplicate Curves. This will make separate curves
for the isoparms that you selected.

Name the larger curve Crosspiece01 and the smaller curve
Crosspiece02.

Hint: Maya allows you to rename nodes when they are initially created. Or you
could also rename the node in question by clicking on the name and changing it in
the Channel Box or Attribute Editor.

10

11

40

With the two new curves selected, go to Edit Curves > Open/Close

Curves.

We will only be using parts of the new curves so delete the unneeded
edit points on the two curves. If your curves lose their shape in this
process, try deleting only one edit point at a time.
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Figure 2.22 Readying the new curves.

Turn on Snap to Points mode.

Select the EP curve tool, then RMB click on the first curve and enter
Edit Point component mode. Click near the top edit point of the curve
and the EP tool will snap the first edit point to that point.

RMB click on the second curve and enter Edit Point component mode.

Click near the top edit point of this second curve and the next EP curve
point will snap to that point.

Press enter to create the EP curve. This is the top guide that will help us
in construction of our crosspiece.

Follow steps 13 to 16 to create the bottom guide.
Turn off Snap to Points.
In the front viewport, create the inner outline for the crosspiece.

Duplicate the outline and adjust the CVs and EPs to form the outer
edge of the outline (see Figure 2.23).
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Figure 2.23 Inner and outer outlines.

21 Duplicate the inner edge twice and the outer edge three times. Place

them according to Figure 2.23.

22 Rename the outline sequentially starting with Outline01 for the curve
aligned with Crosspiece01, to Outline07 for the curve aligned to
Crosspiece02.

23 If you look at the crosspiece outlines, they won't match up with the
guidelines you created. To do this, select the top guideline and RMB
click to Curve Point component mode, select the spot where you want
to create an EP and run Edit Curves > Insert Knot.

24 Turn Snap to Points on.

25 RMB click on an outline curve and enter Edit Point component mode.
Select the end EP.

26 RMB click on the guideline and enter Edit Point mode. Now when you
move the edit point, it will snap to the guideline curve.

27 Repeat steps 26 for the tops of the other outline curves.

28 Once the top is done, follow steps 25 to 27 to complete the bottom.
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Figure 2.24 Adding edit points.

Figure 2.25 The completed outlines.

We are now ready to loft the surfaces for the crosspiece. For this particular
object we are going to loft the surfaces in chunks. This makes it easier to create

slightly rounded edges, which will add to the realism.
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Select Outline01 first, followed by Outline02.

Go to Surfaces > Loft > 0.

Set the Parameterization to Uniform with Auto Reverse.
For Surface Degree use Cubic with a Section Span of 1.

The Curve Range should be set to Complete and choose NURBS for the
Output Geometry.

Click Create.
Next select Outline02 and Outline03 and run Surface > Loft.

Repeat step 35 for Outline03 and 04, Outline04 and 05, Outline05 and
06, and lastly Outline06 and 07.

Select Outline01 followed by Crosspiece01 and go to Surface > Loft.
Select Outline07 followed by Crosspiece02 and go to Surface > Loft.
Select the first loft and second loft surfaces.

Go to Edit NURBS > Attach Surfaces > 0.

Set the Attach Method to Blend and the Blend Bias to .25. Check Insert
Knot options.

Leave Insert Parameter at .100.
Click Attach.

Select this new surface and the second loft surface. Go to Edit
NURBS > Attach Surface.

Repeat step 44 for each loft surface making sure to only attach one
surface per operation. Attach the two surfaces created with the

Crosspiece curves last.

Select the Crosspiece and go to Edit > Duplicate > 3. Set the X scale
to -1 and click Duplicate.

Line the second crosspiece up with the first one.
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Figure 2.26 The completed crosspiece.

Figure 2.27 The completed binoculars.

48 Duplicate the first lens and line it up with the second crosspiece.

49 Go to Create > NURBS Primitives > Cylinder > . Change the Axis to Z
and choose Both for Caps. Click Create.
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50 Place the cylinder in the hole between the two crosspieces and scale it
to fit. This will be the focusing knob.

51 Duplicate this cylinder and move it below the focusing knob. It should
intersect the bottom of each crosspiece. Scale it to fit. This will be the
part that holds the two halves of the binoculars together.

Subdivision Surfaces

Subdivision surfaces (or subD surfaces) are best described as a cross between
polygons and NURBS surfaces. They work by starting with a coarse base mesh for

your model, which is then made finer and finer as you subdivide any desired areas.

One advantage of subdivision surfaces is they can be modeled using a single
surface. This means that the potential of having seams in your models is not
present as they are with NURBS surfaces. Another big advantage is that a
coarse subD surface can be rigged for animation and the information will

automatically transfer to the finer levels.

1  Go to Create > Subdiv Primitives > Cube. This will place a subD cube
in your scene.

2  RMB click on the cube and select Vertex from the marking menu. You
will see a 0 displayed next to each vertex. This indicates that the
vertices are set to base level. The display levels range from zero to
thirteen.

Figure 2.28 A subdivision cube.
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3

4

Select a row of vertices marked by 0.

Go to Subdiv Surfaces > Refine Selected Components. This will refine
the selected vertices to level 1.

You can continue to refine the selected vertices. Repeat step four until you have

the desired smoothness for your vertices. You can also perform refine

operations using faces and edges.

1

2

Start a new scene in Maya.

Create three subD cubes using Create > Subdiv Primitives > Cube and
place them side by side.

Select the upper front row of vertices on the first cube.
Run Subdiv Surfaces > Refine Selected Components twice.

Double click on the Move Tool icon in the Tool Box to bring up the
attribute editor for the tool. For Move Settings select Normal.

Select the N handle and move the vertices a tad in the positive Z.

Repeat steps 3 to 6 for the second cube, selecting the upper front two
edges.

Repeat steps 3 to 6 on the faces of the third cube.

Figure 2.29 Three different manipulated subdivided cubes.
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By refining different components, you get drastically different results. Keep
in mind that you can choose different component types for different levels. Also,
you will get different results if you move the components before refining them.

1  Start a new scene in Maya.

2  Go to Create > Subdiv Primitives > Cylinder to place a subD cylinder in

your scene.
3 RMB click on the cylinder and go into vertex component mode.
4  Select the top center vertex of the cylinder.

5 Go to Subdiv Surfaces > Full Crease Edge/Vertex. This will create
a crease on our selection. Subdivision surfaces excel at creating creases
and edges, something that NURBS surfaces have trouble with.

6 Double click on the Move Tool icon in the Tool Box to bring up the
attribute editor for the tool. For Move Settings select Normal.

7  Move the vertex up on the Y axis. Notice how, because you selected
the full crease tool, the vertex forms a well-defined point on top of the
cylinder.

8  With the vertex still selected go to Subdiv Surfaces > Partial Crease
Edge/Vertex. A partial crease creates a softer edge compared to a full

crease.

9  Use the Move Normal Tool to move the vertex selection on the positive
Y axis until you have a bulb in your scene.

Figure 2.30 Subdivision bulb.
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10 Double click on the Move Tool icon in the tool box to open the attribute

editor.

11 Change the Move Settings to Object. You can switch between the move

settings without losing your selection.

12 Move the vertices down, as in Figure 2.31.

Figure 2.31 Flattened bulb.

13 Select the vertices that form the top of the object and run Subdiv
Surfaces > Refine Selected Components twice to smooth them to level 3.

14 Save your scene as subDMushroom.

Figure 2.32 Final mushroom.

There is another way to work with subdivision surfaces — Polygon Proxy Mode.
When you switch to Polygon Proxy Mode, a polygonal cage surrounds the base

level of your subdivision surface.
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1  Open the mushroom you created in the previous tutorial.
2  Select the object.

3  Go to Subdiv Surfaces > Polygon Proxy Mode. You will see a low
resolution cage appear in your model.

4  Press 4 to switch to wireframe mode. As you can see, the polygonal
cage matches the work you did on the base level of the object.

5 In order to get a polygonal cage to surround your object once you have

refined it, you need to collapse the hierarchy of the levels.

6 Go to Subdiv Surfaces > Standard Mode to return to the standard subD
editing mode.

7  Go to Subdiv Surfaces > Collapse Hierarchy > 3. Type 3 for the
Number of Levels and press Collapse. The number of levels options
refers to how many levels of refinement you want to collapse. You can
collapse up to the number you currently have set for your object.

8 Go to Subdiv Surfaces > Polygon Proxy Mode. The polygonal cage will
now surround the entire mushroom object.

Figure 2.33 Polygon proxy mushroom. Notice the
proxy cage vertices are selected.
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In Polygon Proxy Mode you can use any of the polygonal editing tools on the
new proxy mesh. Experiment with extruding some faces and pulling vertices of
the new polygon cage. The subD surface will deform as well. When you are
happy with your edits, go to Subdiv Surfaces > Standard Mode to return to the
normal subdivision work mode. When you switch back to standard mode, the
polygonal cage will automatically be deleted.

A very common workflow with subdivision surfaces is to start with a low
polygon object that you form into the basic shape you desire. Once you have
the basic form ready the object is converted to subD surfaces using Modify >
Convert > Polygons to Subdiv.

Tutorial: Creating a Hand with Subdivision
Surfaces
1  Start a new scene in Maya.

2 Create image planes in the front and side viewport to template your
hand drawings.

Figure 2.34 Hand drawings to be modeled using subD surfaces.

3  Go to Create > Polygon Primitives > Cube > 0. Set 4 for the
subdivisions along the X, Y, and Z axes. Click Create.

4  Position the cube of the palm of your template.

5  Scale the cube to the approximate dimensions of the palm of your
template. We will be extruding the fingers later.

6  RMB click on the cube and enter Vertex Component mode. Start
moving vertices to get the basic shape of the palm (see Figure 2.35).
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Figure 2.35 Beginning polygon model.

7 Now that you have the basic shape of the palm, it's time to convert it
into subD surfaces. Go to Modify > Convert > Polygons to Subdiv. Your
model will now be smoother. But it still lacks fingers and good palm

definition.

8 Select the model and go to Subdiv Surfaces > Polygon Proxy Mode.
A cage of the original polygonal mesh will surround the subD surface.

9 Select the faces that are in line with the index finger of the sideview

template drawing.

10  Using the polygon toolsets, extrude the faces out to just before the first

knuckle.
11 Adjust the faces so they match the area of the template.

12 Extrude again to the middle of the knuckle and adjust the faces to
match this area.

13 Extrude a third time to just after the knuckle and adjust the faces to
match the template. The reason for extruding in chunks around the
knuckles is because the extra detail in these areas allow for deformation
of the model.

14 Continue extruding in chunks until you have the basic shape of the

index finger.
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15

16

17

18

19

20

21

22

23

24

25

26

Figure 2.36 SubD surface index finger.

Take some time to fine-tune the shape of the index finger. Remember,
during this stage, all of the polygon tools are at your disposal. If you
need to merge vertices or split faces to match the template, now is the
time to do so.

Select the faces that correspond to the fingernail of the index finger.
Extrude them down a very slight amount.

Scale the faces uniformly down a small amount.

Extrude the faces back to their original position.

Split the polygon cage on the sides of the finger to add dimples around
the fingernail.

Pull the vertices in around the fingernail so they overlap the nail.

Use the Split Polygon Tool to create extra faces between the two fingers.
Repeat steps 9 to 22 to shape the other finger.

Select the faces that lie over the thumb in the template.

Extrude them out.

Rotate the selection so that edges nearest the wrist are back near their

starting point. This is an important part of cleaning up the thumb.
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Figure 2.37 Creating extra space between the fingers.

Figure 2.38 Creating the thumb.

27 Merge the vertices that have been rotated back to their starting point
with the vertices that are currently in those coordinates. This step is
vital for creating the bulge of the thumb where it shoots out from
the wrist.

28 Continue manipulating vertices to get the shape for the base of the
thumb.

29 Select and extrude the thumb faces using the same methods as used
for the fingers.

54



MODELING

Figure 2.39 Merging the vertices at the base of the thumb.

Figure 2.40 The base of the thumb.

Figure 2.41 Extruding the thumb.
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31

32

33

34
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Create the nail for the thumb. Remember to use the Split Polygon Tool

to create extra faces so you can overlap them over the thumbnail.

Select the faces at the base of the hand and extrude them back to
make the wrist.

Figure 2.42 Making the wrist.

Once the wrist is extruded, delete the faces of the base. They will not
be needed.

Go to Subdiv Surfaces > Standard Mode. We are now ready to finish
the hand. We can get more finely tuned details in standard subD mode.

Select the rows of edges starting at the wrist and extending to the first

set of knuckles (see Figure 2.43).

Figure 2.43 Edges on the top of hand.
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Figure 2.44 Forming the bones and muscles of the wrist.

35 Go to Subdiv Surfaces > Partial Crease Edge/Vertex. Pull the crease up
a bit to form ridges on the back of the hand.

36 Use the Partial Crease Edge tool to create the bones and muscles of the

wrist.

Figure 2.45 The completed hand.

37 RMB click on the hand and select Vertex Component mode from the

marking menu.

38 Select the vertices for each fingertip.
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39 Go to Subdiv Surface > Refine Selected Components. The fingertips will
now be smoothed to level 1. Keep in mind that with subdivision

surfaces you only need to smooth out areas that need the extra detail.

The images | have used are unique hands for an android | created named
Feedle. Feedle only has a thumb and two fingers on each hand. Of course if
you are modeling a traditional hand, simply repeat the steps for each finger.
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After you create the geometry, you will need to let Maya know the surface
properties of the object. In Maya this is known as a Shading Network. Each
Shading Network you build holds such information as transparency, color,
incandescence, and textures. All of the material work is done in a work area

known as the Hypershade.

The Hypershade

Start a new scene in Maya 5.0, and open the Hypershade by going to
Window > Rendering Editors > Hypershade. You could also select the
Perspective/Hypershade button on the Tool Box to create a stacked window

of the two views.

Figure 3.1 The Hypershade window.

The Hypershade is separated into three main areas. To the left is the node
creation area. This is where you initially create your shading networks. You can
also RMB click in the Hypershade and create these nodes through the marking
menu. The two other key areas of the Hypershade are the top and bottom work
spaces. The top space contains the main node information. You can switch
between node types using the tabs along the top of this area. The bottom
space is the working area where you actually construct the shading networks.
You navigate through the Hypershade using the same mouse and keyboard

command used in moving through Maya’s main menus.

You will notice that there are always three material nodes present. These are

non-deletable nodes that Maya uses as default shaders for new objects.
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Material Types

You have many different material types to choose from when you begin
constructing your shading network. It's very important to choose the correct

material type as they each render differently.

Anistropic — For surfaces with small grooves, like brushed metal or a CD.
As your view of an object with an Anistropic material changes, the highlight

will change depending on the direction of the grooves.

Blinn — For surfaces that have soft specular highlights. Blinn materials are

a good choice for soft metal surfaces.

Lambert — For matte surfaces. Use for object that will have no specular
highlights.

Layered Shader — Use if you want more than one material on an object. Using

a Layered Shader you can mix the added materials to create unique surfaces.

Phong - For use on very glossy surfaces. Phong materials have a hard specular
highlight.

Phong E - Similar to Phong, but with a slightly softer specular highlight. Phong E

also renders faster than a regular Phong.

Ramp Shader — Uses gradients to control color changes of the material
associated with changes of lights and angle.

Shading Map - For creating non-photorealistic surfaces.

Surface Shader - Allows you to connect keyable attributes to the material.
With a Surface Shader you could have an object’s color change automatically as

it moves through the scene.

Use Background - For use with blending real-life images with computer-
generated objects. Objects using the Use Background material will not appear
in your scene, but they are still affected by nodes in your scene. Thus shadows
can still fall on them and they can still accept reflections. If you had a
photograph of a fence and you wanted it to appear that your character walked

behind it, you would create a stand-in object to match the outline of the fence
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and apply a Use Background material to it. If a shadow fell across the stand-in
object, it would appear to actually affect the fence in the photograph.

Texturing Objects Using NURBS

There are two ways to texture your object, procedurally and with image maps.
Procedural textures are generated within Maya using mathematical formulae.
Image maps are user-created files that you import into Maya and place on

an object.

1  Open the binoculars you created earlier.

2  Hide the left barrel and crosspiece. For identical objects it's a good idea
to texture the original piece before you duplicate it. When you
duplicate an object, the Shading Network is transferred onto the new
geometry.

Figure 3.2 Preparing the binoculars for texturing.

3 RMB click on the barrel and select the isoparms that make up the main
lens of the binoculars.
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10

11

Go to Edit NURBS > Detach Surfaces. This will detach the lens into

multiple surfaces.

Select the two separate surfaces of the lens and go to Edit NURBS >
Attach Surfaces > . Set the Attach Method to Connect and the
Multiple Knots to Keep. Press Attach. By attaching the surface in this
way, you get the lens to not distort during the attachment.

Continue attaching until the lens is all one surface.

Check the CVs at the center of the lens and if necessary snap them
together using the Snap to Point tool.

Repeat steps 3 to 7 for the smaller eyepiece lens.

Open the Hypershade by going to Window > Rendering Editor >
Hypershade.

Click once on the Phong icon and once on the Phong E icon in the
Create work area of the Hypershade. If the Create area does not have
the Materials loaded, click on the bar at the top and select Create
Materials from the menu. Also, remember you can RMB click in the work

areas and use the marking menu to create your material.

Double click on the Phong E material swatch in the work area to open
the Attribute Editor.

Tip: If you lose track of the icons in the work area press the a key on your keyboard
to frame all. Remember that you can navigate through here using the regular Maya
controls.

12

13

Click on the checkered box next to the Color setting. This will bring up the
Create Render Node. This window has the same nodes you can access
through the Create window of the Hypershade but if you assign them
through here, they are linked automatically to the Shader Network for you.

In the Create Render Node select the Textures tab and click on Checker.
The reason for applying the checker material is that it helps locate
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Figure 3.3 The Attribute Editor

Figure 3.4 The Create Render Node.
for the Phong E material.

Figure 3.5 The Checker texture.

problem areas on your mesh. With a checker textures assigned, you can

quickly see which areas of your object need work to prevent texture
stretching and crunching.

14 Select the barrel of the binoculars.
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15

16

17
18

Figure 3.6 The Phong E Material checker ready to assign.

Go back to the Hypershade. The Phong E material will now appear as a
checkered sphere.

With your object still selected, RMB click on the checkered Phong E
material and click on Assign Material to Selection in the marking menu.

Press 6 on your keyboard to enter hardware texturing mode.

You will see a checkered barrel similar to Figure 3.7.

Figure 3.7 The checkered barrel.
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Select all of the surfaces for the crosspiece and assign the checkered
Phong E to them.

Select the two lenses and repeat steps 11 through 19 using the Phong
material. This will give the lenses a shinier appearance.

Inspect the checker textures for any stretching. The crosspiece needs a
bit of work.

Select the crosspiece surface and go to Window > Attribute Editor (or
use the Ctrl + a keyboard shortcut).

In the Attribute Editor select the Shape node for the crosspiece.
Click on the arrow next to Texture Map to expand the options.
Click the Fix Texture Warp swatch. Leave the Grid divisions at 4.

This Fix Texture Warp works on a per surface basis. It does not affect

the material you created in any way.

To see the changes this makes to your crosspiece you will need to
render the scene. Center the crosspiece in your Perspective View and

click on Render the Current Frame in the Status Line.

The checker texture is no longer stretched way out of proportion on the
object.

Open the Hypershade and double click on Phong E material. We need
now to replace the checker texture with the one we will be using for

rendering.

Select Graph > Input and Output Connections in the Hypershade

window.

Select the checker texture and the place2dTexture swatches and delete
them. The Phong E material is still mapped to surfaces all we have to do

is add our final texture.
Double click on the Phong E swatch to open the Attribute Editor.

Click on the color bar next to Color to bring up the Color Chooser.
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34

35

36

37

38

39

40

Set each of the RGB values to 37.

If the Color Chooser is in HSV (Hue,
Saturation, and Value) mode click on
the HSV/RGB pulldown in the Sliders
section. If the numerical value
pulldown is set to 0-1, you may want
to change it to 0-255. Most people
are more familiar with the 0-255 color

picking system.

Click on the checker box next to

Bump Mapping.
Set the Bump Depth to .125.

Click on the checker box next to
Bump Value.

The Create Render Node window will
come up. Select Leather from the
3D Textures list.

Enter these attributes:

— Cell color of R 89, G 89, and B 89.

— Crease color of R 51, G 51, and B51.
- Cell Size to .500.

— Density to .488.

- Spottyness to .100.

- Randomness to .500

— Threshold to .909

— Creases checked.

) Color Chooser ,_ 0| x|

[~ [Sliders
m 0 "

mB lend |
u Palette |

docept | Resst | Cancel |

Figure 3.8 The Color Chooser.

Go back to the Hypershade and select the Phong material that is

mapped to the lenses and open it in the Hypershade.

67



THE FOCAL EASY GUIDE TO MAYA 5

41 Enter the following attributes:

Color of R 128, G 128, and B 128.

Transparency of R 198, G 198, and B 198.

Expand the Raytrace Options section and turn on Refractions.
- Refractive index of 1.1.

Refractions Limit of 2.

Surface Thickness of 1.0.

Shadow Attenuation of .5.

42 Now that you have textured this half of the binoculars, duplicate and
position the lenses, crosspiece, and barrel as you did in the modeling
tutorial.

43 Press the Render the Current Frame button to see your final work. Keep
in mind that though we set up the lenses to use a refracted raytraced
material, it will not show up until the final render.

Figure 3.9 The finished binoculars.

Texturing Polygonal and SubD Models

Texturing polygons and subdivision surfaces uses a completely different
workflow from NURBS. NURBS embed the UV information automatically when

68



MATERIALS AND TEXTURES

you create a surface. With polygons and subD surfaces, you actually have to let

Maya know where the UV coordinates lay. This is done using the Texture

commands found in Edit Polygons > Textures and Subdiv Surfaces > Textures.

Mapping polygons and subD surfaces are ess